re = /(https?:\/\/(?:w{1,3}.)?[^\s]*?(?:\.[a-z]+)+)(?![^<]*?(?:<\/\w+>|\/?>))/
str = 'This is my text to be parsed which contains url
http://someurl.com <a href="http://thisshouldnotbetampered.com">
some text and a url http://someotherurl.com test 1q2w </a> <img src="http://someasseturl.com/abc.jpeg"/>
Hello http://someurl.com</a> <!-- fail -->
<img src="http://someurl.com/image.jpg>
http://someurl.localhost.com
<div>Regex is awesome</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end