package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9]+(?: [A-Z]+)*|[A-Z]+(?: [A-Z]+)* [0-9]+)$`)
var str = `75 MANOJ TIGADI
VASANT KANETKAR 111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}