re = /^(?:[0-9]+(?: [A-Z]+)*|[A-Z]+(?: [A-Z]+)* [0-9]+)$/m
str = '75 MANOJ TIGADI
VASANT KANETKAR 111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end