#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)(?<cons>\b(?:" & @CRLF & _
" (?<x>\d*)" & @CRLF & _
" (?:(?<a0>0)|(?<a1>1)|(?<a2>2)|(?<a3>3)|(?<a4>4)" & @CRLF & _
" |(?<a5>5)|(?<a6>6)|(?<a7>7)|(?<a8>8))" & @CRLF & _
" (?:9(?= 9*,\g{x}\d (?<y>\g{y}?+ 0)))*" & @CRLF & _
" ,\g{x}" & @CRLF & _
" (?(a0)1)(?(a1)2)(?(a2)3)(?(a3)4)(?(a4)5)" & @CRLF & _
" (?(a5)6)(?(a6)7)(?(a7)8)(?(a8)9)" & @CRLF & _
" (?(y)\g{y})" & @CRLF & _
" # handle the 999 => 1000 case separately" & @CRLF & _
" | (?:9(?= 9*,1 (?<z>\g{z}?+ 0)))+" & @CRLF & _
" ,1\g{z}" & @CRLF & _
")\b))" & @CRLF & _
"" & @CRLF & _
"# list of two or more consecutive integers" & @CRLF & _
"(?=(?&cons))\d+" & @CRLF & _
"(?:,(?=(?&cons))\d+)*" & @CRLF & _
",\d+"
Local $sString = "0,1,2,3" & @CRLF & _
"8,9,10,11" & @CRLF & _
"1999,2000,2001" & @CRLF & _
"99,100,101" & @CRLF & _
"" & @CRLF & _
"42" & @CRLF & _
" 3,2,1" & @CRLF & _
"1,2,4" & @CRLF & _
"10,11,13"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")