import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?<cons>\\b(?:\n"
+ " (?<x>\\d*)\n"
+ " (?:(?<a0>0)|(?<a1>1)|(?<a2>2)|(?<a3>3)|(?<a4>4)\n"
+ " |(?<a5>5)|(?<a6>6)|(?<a7>7)|(?<a8>8))\n"
+ " (?:9(?= 9*,\\g\\{x\\}\\d (?<y>\\g\\{y\\}?+ 0)))*\n"
+ " ,\\g\\{x\\}\n"
+ " (?(a0)1)(?(a1)2)(?(a2)3)(?(a3)4)(?(a4)5)\n"
+ " (?(a5)6)(?(a6)7)(?(a7)8)(?(a8)9)\n"
+ " (?(y)\\g\\{y\\})\n"
+ " # handle the 999 => 1000 case separately\n"
+ " | (?:9(?= 9*,1 (?<z>\\g\\{z\\}?+ 0)))+\n"
+ " ,1\\g\\{z\\}\n"
+ ")\\b))\n\n"
+ "# list of two or more consecutive integers\n"
+ "(?=(?&cons))\\d+\n"
+ "(?:,(?=(?&cons))\\d+)*\n"
+ ",\\d+";
final String string = "0,1,2,3\n"
+ "8,9,10,11\n"
+ "1999,2000,2001\n"
+ "99,100,101\n\n"
+ "42\n"
+ " 3,2,1\n"
+ "1,2,4\n"
+ "10,11,13";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}