$re = '/(.*?)(?<!\d|\d )((?i:dk)?(?:\d{2}\D?){3}\d{2}(?!\d))/';
$str = 'CVR-nr. DK30344510 / Tlf. 62226420';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);