re = /(.*?)(?<!\d|\d )((?i:dk)?(?:\d{2}\D?){3}\d{2}(?!\d))/
str = 'CVR-nr. DK30344510 / Tlf. 62226420'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end