#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)NL\s?\d{2}\s?[A-Z]{4}0\s?\d{9}$" & @CRLF & _
""
Local $sString = "IBAN NL 91ABNA0417164300" & @CRLF & _
"IBAN NL91ABNA0417164300" & @CRLF & _
"Iban: NL 69 ABNA 401022366"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")