use strict;
my $str = 'IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366';
my $regex = qr/NL\s?\d{2}\s?[A-Z]{4}0\s?\d{9}$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}