package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(AC|AL|AP|AM|BA|CE|DF|ES|GO|MA|MT|MS|MG|PA|PB|PR|PE|PI|RJ|RN|RS|RO|RR|SC|SP|SE|TO|BR)C?-[0-9]{3}`)
var str = `BR-101
ABC-000
ZZZ-999
PRC-280
RSC-453`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}