re = /(AC|AL|AP|AM|BA|CE|DF|ES|GO|MA|MT|MS|MG|PA|PB|PR|PE|PI|RJ|RN|RS|RO|RR|SC|SP|SE|TO|BR)C?-[0-9]{3}/
str = 'BR-101
ABC-000
ZZZ-999
PRC-280
RSC-453'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end