import re
regex = re.compile(r"""
Node[^\]\[]*\[[^\]\[]*label="\{\{(?<SRC>[^{}]*)\}\|(?<NAME>\w+)\s*\[ORD=(?<ORD>\d+)\]\|(?<ID>[^|]*)\|\{(?<DEST>[^{}]*)\}\}"\];
""", flags=re.VERBOSE)
test_str = ("Node0x7fd34984d728:s1 -> Node0x7fd34984d600:d0;\n"
"Node0x7fd34984d850 [shape=record,shape=Mrecord,label=\"{Register %vreg13|0x7fd34984d850|{<d0>i32}}\"];\n"
"Node0x7fd34984d978 [shape=record,shape=Mrecord,label=\"{{<s0>0|<s1>1}|CopyFromReg [ORD=1]|0x7fd34984d978|{<d0>i32|<d1>ch}}\"];\n"
"Node0x7fd34984d978:s0 -> Node0x7fd3486095f0:d0[color=blue,style=dashed];\n"
"Node0x7fd34984d978:s1 -> Node0x7fd34984d850:d0;\n"
"Node0x7fd34984daa0 [shape=record,shape=Mrecord,label=\"{Register %vreg14|0x7fd34984daa0|{<d0>i32}}\"];\n\n"
"SRC=<s0>0|<s1>1, NAME=CopyFromReg , ID=0x7fd34984d978, DEST=<d0>i32|<d1>ch, ORD=1 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")