re = /Node[^\]\[]*\[[^\]\[]*label="\{\{(?<SRC>[^{}]*)\}\|(?<NAME>\w+)\s*\[ORD=(?<ORD>\d+)\]\|(?<ID>[^|]*)\|\{(?<DEST>[^{}]*)\}\}"\];/x
str = 'Node0x7fd34984d728:s1 -> Node0x7fd34984d600:d0;
Node0x7fd34984d850 [shape=record,shape=Mrecord,label="{Register %vreg13|0x7fd34984d850|{<d0>i32}}"];
Node0x7fd34984d978 [shape=record,shape=Mrecord,label="{{<s0>0|<s1>1}|CopyFromReg [ORD=1]|0x7fd34984d978|{<d0>i32|<d1>ch}}"];
Node0x7fd34984d978:s0 -> Node0x7fd3486095f0:d0[color=blue,style=dashed];
Node0x7fd34984d978:s1 -> Node0x7fd34984d850:d0;
Node0x7fd34984daa0 [shape=record,shape=Mrecord,label="{Register %vreg14|0x7fd34984daa0|{<d0>i32}}"];
SRC=<s0>0|<s1>1, NAME=CopyFromReg , ID=0x7fd34984d978, DEST=<d0>i32|<d1>ch, ORD=1 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end