package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.u..)`)
var str = `ul.da.ul.a.ul.ul.
ul.ul.a.a.a
ul.aaaa.ul.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}