$re = '/(.u..)/m';
$str = 'ul.da.ul.a.ul.ul.
ul.ul.a.a.a
ul.aaaa.ul.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);