$re = '/\((.+\.\w{3})\|(\w{1,8})\)/m';
$str = 'Farkas=(Skyrim.esm|1A692) // Causes issues when transforming back from werewolf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);