// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.+\.\w{3})\|(\w{1,8})\)").unwrap();
let string = "Farkas=(Skyrim.esm|1A692) // Causes issues when transforming back from werewolf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}