import Foundation
let pattern = #"(?:Debug:\s(.+?(?=endmsg)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)