$re = '/id=(.*?)(?=&|$)/m';
$str = 'http://example.com?id=222&haha=555
http://example.com?id=222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);