re = /id=(.*?)(?=&|$)/m
str = 'http://example.com?id=222&haha=555
http://example.com?id=222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end