use strict;
my $str = '<variable class="loves">[loves] My dog loves dog food gloves </variable>
<variable class="loves">[loves] My dog hates dog food </variable>';
my $regex = qr/(?<=<variable[^>]*>[^>]*)\bloves\b(?!(?<=\[[^][]*)[^][]*])(?=[^<]*</variable)/mp;
my $subst = 'hates';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";