$re = '/(?<=<variable[^>]*>[^>]*)\bloves\b(?!(?<=\[[^][]*)[^][]*])(?=[^<]*</variable)/m';
$str = '<variable class="loves">[loves] My dog loves dog food gloves </variable>
<variable class="loves">[loves] My dog hates dog food </variable>';
$subst = "hates";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;