const regex = /^.*\/(?<page>[^?]+)\?.*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\\/(?<page>[^?]+)\\?.*$', '')
const str = `https://local.host.com/order/faces/Home/myorder/exampleproduct?_adf.ctrl-state=mfun9p14r_19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}