re = /^.*\/(?<page>[^?]+)\?.*$/
str = 'https://local.host.com/order/faces/Home/myorder/exampleproduct?_adf.ctrl-state=mfun9p14r_19'
# Print the match result
str.match(re) do |match|
puts match.to_s
end