import Foundation
let pattern = #"(<ComponentSearchFormField(?:[^<]*?))(\s+)type="inputSearch"((?:[^>]*?)\/>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div className="ui celled grid">
<div className="row">
<ComponentSearchFormField
columnWidth="8"
type="inputSearch"
model={depositPrototype}
field="company"
sourceCollection={Companies}
baseCriteria={{isActive: true}}
/>
<ComponentSearchFormField
disableValidation
type="inputSearch"
model={depositPrototype}
disableValidation
title="Currency Code"
sourceCollection={CurrencyCodes}
baseCriteria={{isActive: true}}
/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}