package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\w+(-\w+)+)`)
var str = `fhkjhjfsa fjasio-fakjfas-fjsahjfkas fajskl-fas fhsajhfkjsa
fasjlk-fas-jfksaljfklas fasfjsak jkfs kflaj s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}