#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^(" & @CRLF & _
" ( # define some frequently used capture groups" & @CRLF & _
" (?!x)x # always false ("match only if there is no 'x' ahead and there is 'x' ahead")" & @CRLF & _
" (?<name>[^_]+) # group "name", name of the program/library" & @CRLF & _
" (?<os>windows|linux|osx|android|illumos) # group "os", operating systems" & @CRLF & _
" (?<arch>x86-64|x86|arm64|armhf|armel) # group"arch", architectures" & @CRLF & _
" (?<buildtype>release|debug) # group"buildtype", build types" & @CRLF & _
" (?<linking>shared|static|mixed) # group "linking", library linking/build types" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ( # regular executable builds" & @CRLF & _
" (?!lib)\g<name>_build_\g<os>_\g<arch>_\g<buildtype>" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ( # library builds" & @CRLF & _
" lib\g<name>_build_\g<os>_\g<arch>_\g<linking>_\g<buildtype>" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ( # syncing source code of a project from git or something else" & @CRLF & _
" \g<name>_src" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ( # static code analizer" & @CRLF & _
" \g<name>_analyze_(cppcheck|scan-build)" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ( # package builds" & @CRLF & _
" \g<name>_pkg_\g<os>_" & @CRLF & _
" (" & @CRLF & _
" ((?<=linux_) # if there is "linux_" before here" & @CRLF & _
" ( # then match" & @CRLF & _
" deb|rpm" & @CRLF & _
" )_" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" ((?<!linux_)) # if there is no "linux_", don't match anything" & @CRLF & _
" )" & @CRLF & _
" \g<arch>_(stable|nightly)_\g<buildtype>" & @CRLF & _
" )" & @CRLF & _
")$"
Local $sString = "libtoxcore_build_linux_arm_mixed_debug"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")