package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(
( # define some frequently used capture groups
(?!x)x # always false ("match only if there is no 'x' ahead and there is 'x' ahead")
(?<name>[^_]+) # group "name", name of the program/library
(?<os>windows|linux|osx|android|illumos) # group "os", operating systems
(?<arch>x86-64|x86|arm64|armhf|armel) # group"arch", architectures
(?<buildtype>release|debug) # group"buildtype", build types
(?<linking>shared|static|mixed) # group "linking", library linking/build types
)
|
( # regular executable builds
(?!lib)\g<name>_build_\g<os>_\g<arch>_\g<buildtype>
)
|
( # library builds
lib\g<name>_build_\g<os>_\g<arch>_\g<linking>_\g<buildtype>
)
|
( # syncing source code of a project from git or something else
\g<name>_src
)
|
( # static code analizer
\g<name>_analyze_(cppcheck|scan-build)
)
|
( # package builds
\g<name>_pkg_\g<os>_
(
((?<=linux_) # if there is "linux_" before here
( # then match
deb|rpm
)_
)
|
((?<!linux_)) # if there is no "linux_", don't match anything
)
\g<arch>_(stable|nightly)_\g<buildtype>
)
)$`)
var str = `libtoxcore_build_linux_arm_mixed_debug`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}