using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+@\w{2,}\.\w{2,4}";
string input = @"basile.arnaud00@gmail.com
basilearnaud@orange.fr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}