re = /.+@\w{2,}\.\w{2,4}/
str = 'basile.arnaud00@gmail.com
basilearnaud@orange.fr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end