import re
regex = re.compile(r"(?=Abrechnungsprotokoll für Vera).*(?<=Abzurechnende Sätze)", flags=re.DOTALL)
test_str = ("\n\n\n\n\n\n\n\n\n\n\n\n\n"
" relocation ist ein geschütztes UNISERV Software-Produkt \n\n"
" und darf nur auf der EDV-Anlage der Firma \n\n\n"
" BayWa AG\n\n"
" Arabellastr. 4\n\n"
" 81925 München\n\n\n"
" verarbeitet werden. \n\n"
" Eine Mitbenutzung durch Dritte wurde vertraglich ausgeschlossen. \n\n\n"
" Programminstallation 14.02.2017\n\n"
" Version 2.17-2\n\n\n"
" Bei Fragen wenden Sie sich bitte an \n\n\n"
" UNISERV GmbH \n\n"
" Rastatter Strasse 13 \n\n"
" D-75179 Pforzheim \n\n"
" Tel. +49 7231 936-3030, Fax +49 7231 936-2500 \n\n"
"PA Clean Abrechnungsprotokoll Uniserv Test UNISERV GmbH 31.01.2018 17:20:55 Seite 1 von 2 \n\n\n\n"
" Abrechnungsprotokoll für Verarbeitungsnummer: 47 Produktivverarbeitung\n\n\n\n"
" Abgleich: ident \n"
" Bestandsabgleich durchgeführt am 31.01.2018 17:20.55\n"
" Erstelldatum Pool: 01.12.2017 12:27.26 \n"
" Anzahl Pooldatensätze: 18724759\n\n\n"
" Kundensätze gesamt 891080\n\n\n"
" Trefferklassen VS | UZ1 | UZ2 \n"
" --------------------------------------------------------------------------\n\n"
" Treffer PA Clean insgesamt (Brutto) 13672 3796 172\n\n"
" Klasse A 13672 3796 172\n"
" Klasse B 0 0 0\n"
" Klasse C 0 0 0\n\n"
" Treffer PA Clean o. Folgedub. (Netto) 13670 3795 172\n\n\n\n"
" Abzurechnende Sätze 17637\n"
"PA Clean Abrechnungsprotokoll Uniserv Test UNISERV GmbH 31.01.2018 17:20:55 Seite 2 von 2 \n\n\n\n"
" Abrechnungsprotokoll für Verarbeitungsnummer: 47/1 Produktivverarbeitung\n\n\n\n"
" Abgleich: ident \n"
" Bestandsabgleich durchgeführt am 31.01.2018 17:20.55\n"
" Erstelldatum Pool: 01.12.2017 12:27.26 \n"
" Anzahl Pooldatensätze: 18724759\n\n\n"
" Kundensätze für List-id 00001/Gesamt 891080\n\n\n"
" Trefferklassen VS | UZ1 | UZ2 \n"
" --------------------------------------------------------------------------\n\n"
" Treffer PA Clean insgesamt (Brutto) 13672 3796 172\n\n"
" Klasse A 13672 3796 172\n"
" Klasse B 0 0 0\n"
" Klasse C 0 0 0\n\n"
" Treffer PA Clean o. Folgedub. (Netto) 13670 3795 172\n\n\n\n"
" Abzurechnende Sätze 17637\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")