using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'((?:[^']|'')*?)'(?!')";
string input = @"server ('m1.labs.terad ata.com') username ('us ''er5') password('user)5') dbname ('def\\ault')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}