re = /'((?:[^']|'')*?)'(?!')/
str = 'server (\'m1.labs.terad ata.com\') username (\'us \'\'er5\') password(\'user)5\') dbname (\'def\\\\ault\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end