import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z ,.&#\\/0-9-]|&|\\\\n)+?)(\\d{10})([A-Z a-z]+)?(\\d{1}-\\d{7}-\\d{3}-\\d{4}|\\d{1}-\\d{7}-\\d{2}-\\d{4})";
final String string = "\\nTHIS IS FIRST PATTERN 63101 0789158126 0-0000000-000-0000\\n4415 THIS IS FIRST \\nPATTERN 49401-9528\\n0406842931 Third match 0-0000000-000-0000\\n11403 THIS IS FIRST PATTERN 49401-\\n9595\\n0112853789 Third match 0-0000000-000-0000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}