$re = '/((?:[A-Z ,.&#\/0-9-]|&|\\\\n)+?)(\d{10})([A-Z a-z]+)?(\d{1}-\d{7}-\d{3}-\d{4}|\d{1}-\d{7}-\d{2}-\d{4})/';
$str = '\\nTHIS IS FIRST PATTERN 63101 0789158126 0-0000000-000-0000\\n4415 THIS IS FIRST \\nPATTERN 49401-9528\\n0406842931 Third match 0-0000000-000-0000\\n11403 THIS IS FIRST PATTERN 49401-\\n9595\\n0112853789 Third match 0-0000000-000-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);