const regex = /<{1}\w+[\w\s\'\"\=]*(on[^=-\s]+)=["']([\S\w\d]*|[\S\w\d ]*)["']>{1}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<{1}\\w+[\\w\\s\\\'\\"\\=]*(on[^=-\\s]+)=["\']([\\S\\w\\d]*|[\\S\\w\\d ]*)["\']>{1}', 'gmi')
const str = `<video><source onerror="alert(1)"> <img onerror="alert(shouldMatch)">
onerror="shouldnt match"
<img alt="" onerror="alert(2>4)">
<img onerror="alert(2<4)"><img onerror="alert(2<4)">
<img onerror="alert(!@#\$%^&*() <> ""''?|\\/}{][=-_)">
<img onerror="alert()">
<img onerror="(function{}())">
<img onerror="">
<img onerror="asdasdasd(){}((({}0123><456789!@#\$%^&*()_+qwertyuiop[]asdfghjkl;'\\/.,mnbvcxz\\|ZXCVBNM<>?|":LKJHGFDSAQWERTYUIOP{}\`\`~~">
<asd><img onerror="(function{}())">
<img diabled alt="asd" onerror="(function{}())"> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}