# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<{1}\w+[\w\s\'\"\=]*(on[^=-\s]+)=[\"']([\S\w\d]*|[\S\w\d ]*)[\"']>{1}"
test_str = ("<video><source onerror=\"alert(1)\"> <img onerror=\"alert(shouldMatch)\"> \n\n"
"onerror=\"shouldnt match\"\n\n"
"<img alt=\"\" onerror=\"alert(2>4)\"> \n\n"
"<img onerror=\"alert(2<4)\"><img onerror=\"alert(2<4)\">\n\n"
"<img onerror=\"alert(!@#$%^&*() <> \"\"''?|\\/}{][=-_)\">\n\n"
"<img onerror=\"alert()\"> \n"
"<img onerror=\"(function{}())\"> \n"
"<img onerror=\"\">\n\n"
"<img onerror=\"asdasdasd(){}((({}0123><456789!@#$%^&*()_+qwertyuiop[]asdfghjkl;'\\/.,mnbvcxz\\|ZXCVBNM<>?|\":LKJHGFDSAQWERTYUIOP{}``~~\">\n\n"
"<asd><img onerror=\"(function{}())\">\n"
"<img diabled alt=\"asd\" onerror=\"(function{}())\"> ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.