using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ ._\-E](\d{1,4})[ ._\-])";
string input = @"[TEST](TRUC)One.pi.s01.ece.333.cccc.44.ne.33.xx.s01.xx.Piece.712.FANSUB.VOSTFR.(BIDULE).720p.[MACHIN].HDTV.x264-Kaerizaki";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}