package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)([ ._\-E](\d{1,4})[ ._\-])`)
var str = `[TEST](TRUC)One.pi.s01.ece.333.cccc.44.ne.33.xx.s01.xx.Piece.712.FANSUB.VOSTFR.(BIDULE).720p.[MACHIN].HDTV.x264-Kaerizaki`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}