use strict;
my $str = '“windows-1252 quotesâ€';
my $regex = qr/[^\w-=+()!@#$%^*(]/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";