$re = '/[^\w-=+()!@#$%^*(]/mi';
$str = '“windows-1252 quotesâ€';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;