const regex = /<div(?!<div).*?\[label\*(.*?)\].*?<div/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div(?!<div).*?\\[label\\*(.*?)\\].*?<div', 'gs')
const str = `<div class="sect1" id="s9781473910270.i101">
<div class="sect2" id="s9781473910270.i102">
<h1 class="title">1.2 Summations and Products[label*summation]</h1>
<p>text</p>
<div class="sect1" id="s9781473910270.i103">
sometext [ref*summation]
<div class="figure" id="s9781473910270.i220">
<div class="metadata" id="s9781473910270.i221">
<p>fig1.2 [label*somefigure]</div>
sometext [ref*somefigure] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}