$re = '/<div(?!<div).*?\[label\*(.*?)\].*?<div/s';
$str = '<div class="sect1" id="s9781473910270.i101">
<div class="sect2" id="s9781473910270.i102">
<h1 class="title">1.2 Summations and Products[label*summation]</h1>
<p>text</p>
<div class="sect1" id="s9781473910270.i103">
sometext [ref*summation]
<div class="figure" id="s9781473910270.i220">
<div class="metadata" id="s9781473910270.i221">
<p>fig1.2 [label*somefigure]</div>
sometext [ref*somefigure] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);