const regex = /^\d{8,}|SC\d{6,}|NI\d{6,}|OC\d{6,}|RO\d{6,}|SO\d{6,}$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{8,}|SC\\d{6,}|NI\\d{6,}|OC\\d{6,}|RO\\d{6,}|SO\\d{6,}$', 'gi')
const str = `04120742`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}