// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\d{8,}|SC\d{6,}|NI\d{6,}|OC\d{6,}|RO\d{6,}|SO\d{6,}$").unwrap();
let string = "04120742";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}