package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([\\n0-9\$\-,]*)`)
var str = `\n1ST TEST TEST
\n$300`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}