$re = '/([\\\\n0-9\$\-,]*)/im';
$str = '\\n1ST TEST TEST
\\n$300';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);