#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w+.]+@\w+\.[\w.]+"
Local $sString = "All of these emails should be valid (matched by the Regex):" & @CRLF & _
"" & @CRLF & _
"tes.t@gmail.co.uk" & @CRLF & _
"q@q.com" & @CRLF & _
"a+2@gmail.com" & @CRLF & _
"+sd@gmail.com" & @CRLF & _
"a++abc@gmail.com" & @CRLF & _
"" & @CRLF & _
"All of these emails should be INVALID:" & @CRLF & _
"" & @CRLF & _
"·$(")@gmail.com" & @CRLF & _
"(((@q.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")