re = /[\w+.]+@\w+\.[\w.]+/
str = 'All of these emails should be valid (matched by the Regex):
tes.t@gmail.co.uk
q@q.com
a+2@gmail.com
+sd@gmail.com
a++abc@gmail.com
All of these emails should be INVALID:
·$(")@gmail.com
(((@q.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end