# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?im)^([a-z]+).*(\r?\n[^a-z].*)*"
test_str = ("Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]\n"
"(IUPAC: Disilver sulfide)\n"
"Acetamide (1974-039) 10.AA.20 [21] [22] [23]\n"
"(IUPAC: Acetic acid amide)\n"
"Achalaite (2013-103) 04.?? [24] [no] [no]\n"
"Achavalite (Y: 1939")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.